2. Timeline

The Timeline module can be broken up into different subsets of tools. Each subset corresponds to a specific window section of the Timeline module (with the notable exception of the Color Correction Tools which have their own window). This section of the manual focuses on the Timeline Editor window section, which is used for organizing media, cues, effects, etc.

The lower section of the Timeline window is called the Timeline Editor and regroups the tools you will use to edit a Show. Shows are constructed by placing Clips sequentially in the tracks of the Timeline.

The horizontal axis of the Timeline shows the time progression of a Show, expressed in hours:minutes:seconds:frames.

Screens (see Section 2.1.2 Screens in Chapter 4 Programming a Show) are positioned on the vertical axis of the Timeline. Each Screen can contain one or many Layers, which in turn contain different types of Clips: media, cues, effects, etc.

2.1 Sequences, Screens, Layers and Clips

Many different structures are used to organize media, cues, effects, etc. on the Timeline. Make sure you have a good understanding of what these structures do and how they are used. The following sections of the manual (from 2.1.1 to 2.5.4) provide information on how Sequences, Screens, Layers and Clips are used.

2.1.1 Sequences

A Sequence contains all of the Screens, Layers and Clips used in a project, and it provides a representation of the Show’s temporal structure. This is where you will organize and edit media, cues, effects, etc.

A project can have multiple Sequences, but you can only render one Sequence at a time (i.e. the Sequence that is currently selected). Additional Sequences can be used as editing bins to build specific segments of a Show or to hold alternative versions of it.

Select a Sequence

To select a Sequence:

  • Click on a Sequence tab to activate a specific Sequence and access its content.

Create a Sequence

There are three ways to create a new Sequence:

  • Click on the [+] button located to the right of the Sequence tabs; or

  • Press [Ctrl+T] with the Timeline module in focus; or

  • Select {File > Add sequence} from the Timeline menu bar.

Delete a Sequence

To delete a Sequence:

  1. [Right-click] on the tab linked to the Sequence you want to delete. This will give you access to its contextual menu.

  2. Select {Delete} from the contextual menu.

2.1.2 Screens

Any 3D object that was created or imported in the 3D Scene will become a Screen (with the notable exception of Decorative Objects). Screens are virtual structures that represent real-world projection screens. A Screen will coexist in the 3D Scene module (where it is created, then calibrated) and in the Timeline module. Each Screen has its own section of the Timeline, where you can create all of the Layers it will hold.

Create Screens

Screens are not created in the Timeline module per se. When a 3D object is added in the 3D Scene, PHOTON will automatically recognize it as a Screen. A newly created Screen will add its own section to the Timeline.

Collapse and Expand Screens

In order to collapse or expand a Screen you can either:

  • Double-click on the Screen’s Layer; or

  • Click on the small triangle located beside the Screen’s name.

Add Screen Metadata

It is possible to add text metadata to a Screen by accessing the Screen Properties (see Section 5 Clip Properties in Chapter 4 Programming a Show). The metadata attached to a Screen can be used to show or hide specific Screens when executing a search command. For example, if you add text metadata such as “Aisle Screens” to some of the Screens as a way to identify them, you can easily find them when performing a search.

Screen Render Resolution

Screens have a render resolution. The render resolution represents the amount of pixels used to display images on a Screen. You can set a Screen’s render resolution by adjusting its width and height parameters in the Screen Properties (see Section 5 Clip Properties in Chapter 4 Programming a Show).

When determining a Screen’s resolution many different factors need to be taken into account: the Screen’s physical size, its ratio, the distance between its position and the audience, and the resolution of the media that will be displayed on it should be considered. The best practice when choosing resolution is to match the ratio of the Screen and the resolution of the media that will be displayed on it. Insufficient resolution will result in a pixelated image. Using a higher resolution than the media being displayed is a waste of computing resources.

Search for a Screen

A search box is located at the top of the Layers list. You can enter text in the box to filter out some of the Screens on the list.

Screens that remain visible in the Layers list will be the ones that match the name or metadata tag entered into the search box. Note that the names of the 3D objects from which the Screens originate are taken into account by the search box filter.

The Root

The Root can be thought of as an invisible Screen that holds various Clip types (see Section 2.2 Clip Types in Chapter 4 Programming a Show). These Clips are independent from any of the actual Screens created in the 3D Scene. Clips placed in the Root can be referenced by other Clips (such as Proxy Clips, Stack FX Clips, FX Graph Clips, etc.).

It is considered a best practice to place Cue Clips in the Root because by doing this they will appear at the top of all of the other Screens. Also, since the search box filter affects the visibility of the Screens but not the Root, Cues placed in the Root will always be visible.

2.1.3 Layers

Layers are represented as horizontal tracks in the Timeline. They can store many Clips horizontally. Layers can be stacked up vertically to create composited scenes. Layers are also useful when building real-time effects by combining multiple Stack FX Clips. They are also useful in contexts where automation relies Cue Clips.

Unlike Adobe After Effects, PHOTON’s Layers can hold many clips.

Create New Layers

To create a new Layer:

  1. Select one of the Screens (or the Root) by clicking on its entry in the Layers list;

  2. Click on the [+] button located in the Master Layer panel.

The new Layer will be added at the bottom of the Layers list.

By pressing [Ctrl++] the new Layer will be inserted directly below the Layer that is currently selected.

A newly created Layer might not be immediately visible. You have to [Double-click] on the Screen or on the triangle found next to the Screen’s name in order to reveal the Layers stored inside it.

Reorganize the Layer Order

All Layers can be manipulated with the mouse in order to change their position in the Layers list:

  • [Click+Drag+Drop] any Layer to where you want it.

Layers can also be dragged from one Screen to another using the same method.

Layer Rendering Order

In PHOTON, the rendering order is organized sequentially, from top to bottom. This means the lowest item in the list will always be the last one rendered, and as a result it will be placed on top of the composition. This design applies to both the Timeline module (where compositing is done) and the 3D Scene list.

It is important to remember that the logic of PHOTON’s rendering order is the inverse of Adobe’s image compositing software.

2.1.4 Clips

A Clip is a container that can hold various time-based components such as media, cues, effects, etc. (see Section 2.2. Clip Types in Chapter 4 Programming a Show for a complete list of the Clip types and their description).

Clips are placed within Layers (which in turn are placed in Screens, or in the Root). Stacking Clips vertically in the Layers belonging to the same Screen (or in the Root) will allow the creation of visual compositions through Layer blending (see Section 4.3 Blending – Create Compositions in Chapter 4 Programming a Show).

Clips have a fixed duration defined by their borders. By default, the duration of the newly created Clip will match the duration of the whole project.

The Clip’s default duration can be changed by entering a new temporal value for Clips in the field located in the Timeline Default values window. To access the Timeline Default values window click on the General tab in the Settings module.

Add Clips

  • [Right-click] on any track on the Timeline (each Layer has a its own track) to open a contextual menu that contains the following options for adding new Clips (or use the dedicated shortcuts in the Timeline module):

  • Add Empty Clip [Ctrl+N]

  • Add Media Clip (Image, Video, Sound) [Ctrl+M]

  • Add FX Stack Clip [Ctrl+E]

  • Add FX Graph Clip [Ctrl+W]

  • Add Virtual Projector Clip [Ctrl+R]

  • Add Input Device Clip [Ctrl+I]

  • Add Cue Clip [Ctrl+U]

  • Add Proxy Clip [Ctrl+P]

  • Add Composer Clip [Ctrl+G]

  • Add Composition Clip [Ctrl+H]

  • Add Shadow Session Clip [Ctrl+O]

  • [Drag+Drop] a media file from the File Manager module onto a track to create a new Media Clip.

Select a Single Clip

  • Click on a Clip to select it.

Select Multiple Clips

  • [Ctrl+Click] on Clips; or

  • Draw a selection square across the Layers to perform a group selection. (This only works if you draw the selection square within the tracks (identified by the lighter grey area.)

The selection square works across Screens.

Delete Clips

  • Select the Clips you want to delete and press the [Delete] key. A Confirmation Box will open to make sure you really want to delete the Clip. Click on the [Delete] key to delete the Clip.

Change Clip Type

Clip capacities (media playback, send a cue, etc.) are defined by their type (media, cue, effect, etc.). A Clip type is selected whenever a Clip is created.

You can also change a Clip type later on without affecting its duration or location in the Timeline by doing the following:

  • Select the Clip and then select an option from the Clip Type dropdown menu located in the Shared Clip Properties window section of the Timeline module.

The Clip type cannot be changed when multiple Clips are selected.

Change Clip Colors

  1. [Right-click] on a Clip (or a group of multi-selected Clips).

  2. Select {Change color} from the contextual menu. A color picker pop-up window will open. Choose the desired color and close the color picker.

Reset Clip Colors

  1. [Right-click] on a Clip (or a group of multi-selected Clips).

  2. Select {Reset color} from the contextual menu. The selected Clips will reset their color to the default specified in the Settings module.

Change a Clip Type Color

  1. Press [Alt+S] or select {System > Settings} to open the Settings module.

  2. Click on the General tab to access the Default Clip Colors list.

  3. Click on any of the Clip type buttons in the list to open a color picker pop-up window. Choose the desired color and close the color picker.

2.2 Clip Types

Empty Clip [Ctrl+N]

Empty Clips act as empty shells that don’t contain anything. They are mainly used to add operation notes in the Timeline. The default color for representing Empty Clips is grey.

Media Clip [Ctrl+M]

Media Clips contain different kind of media: single frame images, videos and sound files. The default color for representing Media Clips is red.

FX Stack Clip [Ctrl+E]

FX Stack Clips act as adjustment Layers, transforming one or two sources with real-time effects (blur, glow, etc.). There are more than one hundred different kinds of effects. The default color for representing FX Stack Clips is light blue.

FX Graph Clip [Ctrl+W]

FX Graph Clips refer to a specific Graph created in the FX Graph module. The FX Graph module is a graphical programming interface that is used to create effects, manage particles, program logic functions and integrate incoming data from the 3D Scene. The default color for representing FX Graph Clips is deep blue.

Virtual Projector Clip [Ctrl+R]

Virtual Projector Clips re-project content from a point of view defined by the position and orientation of its corresponding Virtual Projector in the 3D Scene. They virtually project images onto Screens, modifying their texture in the process. Virtual Projector Clips are often used in interactive effects used in combination with camera mapping. The default color for representing Virtual Projector Clips is yellow.

Input Device Clip [Ctrl+I]

Input Device Clips refer to input devices such as video acquisition cards, cameras and NDI streams accessed through the I/O module. An Input Device Clip will display its texture (the incoming video feed) onto the Screens they are placed in. The default color for representing Input Device Clips is mauve.

Cue Clip [Ctrl+U]

Cue Clips refer to Cues which are macro commands created with the help of the Cue Editor module. They are triggered by PHOTON when the Playhead intersects with the boundaries of the Clip. The default color for representing Cue Clips is green.

Proxy Clip [Ctrl+P]

Proxy Clips allow you to distribute a reference texture originating from another Clip to other Screens. The source Clip (media, live input, etc.) is usually placed in the Root. Using Proxy Clips reduces the load on the GPU and the disks because the texture is only read once even if its content is displayed on multiple Screens. The default color for representing Proxy Clips is purple.

Composer Clip [Ctrl+G]

Composer Clips allow you to “bake” a visual composition (a single image composed of many Layers of content) that can be referenced to by Clips placed on a Layer below in the Timeline. This is very useful because most of the parameters set in the Shared Clip Properties are not transferred when sourcing Clips in PHOTON. The default color for representing Composer Clips is orange.

Composition Clip [Ctrl+H]

This feature is still in development and should not be used in Shows. Composition Clips allow you to encapsulate a section of the Timeline into a Sub-Timeline that can be visualized by opening the tray at the bottom of the Timeline window. The default color for representing Composition Clips is brown.

Shadow Session Clip [Ctrl+O]

Shadow Session Clips allow you to playback PSN (PosiStageNet) data recordings. The default color for representing Shadow Session Clips is aqua.

2.3 Screen and Layer Timeline Properties

Three toggles and a slider are located to the right of the Screens and the Layers in the Timeline. They can be used in the following ways to affect both Screens and Layers:

Cancel Rendering for a Screen or Layer

  • Click on the Lighting toggle to cancel all image rendering for its corresponding Screen or Layer on the connected Display Servers.

Cancelling image rendering makes manipulation invisible in its corresponding Layer or Screen.

Lock a Screen or Layer

  • Click on the Lock toggle to prevent any modifications to its corresponding Screen or Layer.

The Lock prevents unwanted changes.

Hide a Screen or Layer

  • Click on the Eye toggle to turn its corresponding Screen or Layer to black.

Modify Alpha for a Screen or Layer

  • [Click+Drag] the Alpha slider to modify the alpha channel value for its corresponding Screen or Layer.

2.4 Add or Replace Media

Add Media

  1. Create a new empty Media Clip on the Timeline by using one of these methods:

    1. [Right-click] on a Layer track and select the {Add Media} option from the contextual menu; or

    2. Click on a Layer to select it, then press [Ctrl+M].

This will create a Media Clip with a duration that corresponds to the duration of the Timeline.

  1. Click on the empty Media Clip to select it. The Clip Properties window section of the Timeline module will reflect your selection and its name will change to “Media Properties.”

  2. Select an item from the Media File list by clicking on its entry. The selected media file will be loaded onto the Media Clip and will loop to match the Clip’s duration.

Add a Specific Media File as a Media Clip in the Timeline

  • [Drag+Drop] a media file from the File Manager module onto the Timeline. A new Media Clip linked to the selected media file will be created. The Clip’s duration will match the duration of the media file (even if it is a single frame or still image).

Replace the Media File linked to a Media Clip

There are two methods to replace the media file linked to a Media Clip on the Timeline:

  • Click on the Media Clip to select it and then [Double-click] on the desired media file located in the File Manager module; or

  • Click on the Media Clip to select it and choose a media file from the Media File list located in the Media Properties window section.

None of these actions will alter the duration of the Media Clip.

2.5 Timeline Navigation

2.5.0 The Playhead

The Playhead is a mobile time marker that reads the Timeline’s content and indicates the current time of the Show. It is represented by a downward-pointing red triangle located on the Timeline.

2.5.1 Playhead Positioning

Position Playhead using the Mouse

Use the following methods to position the Playhead with your mouse:

  • [Left-click+Drag] inside the black area of the Timeline (also known as the Time Bar) to move the Playhead; or

  • [Left-click+Drag] the Playhead to move it across the Time Bar; or

  • [Double-click] in the black area of the Timeline (also known as the Time Bar) to make the Playhead jump to that position.

Position Playhead using the Time Box

The Time Box is a field located at the upper left side of the Timeline Editor, which displays the Show’s current time in numeric values. Use the following methods to move the Playhead to a time value specified in the Time Box:

  • Double-click or press [F2] to edit the numeric value in the Time Box.

  • Double-click or press [F2], then press the [+] key and add the number of frames you want the Playhead to move forward. If the number entered is preceded by the [-] key, the Playhead will jump backward. If the number entered exceeds 99, the time value will be divided as follows: hours:minutes:seconds:frames. For example, entering + 122 will make the Playhead jump forward 1 second 22 frames.

Other Ways to Position the Playhead

It is possible to move the Playhead using other methods:

  • Click on the transport buttons located to the left of the Timeline Editor window section to move the Playhead.

  • Many keyboard shortcuts will move the Playhead. A list of the shortcuts linked to the Timeline module can be accessed by selecting {Help > Shortcut Keys > Timeline Shortcuts} in the Main Menu bar.

  • Trigger a Cue containing a pre-recorded change to the Playhead’s position.

  • Select a predefined Region by clicking on its entry in the Region list (located in the far left part of the Timeline editor window section) to make the Playhead jump to the Region’s location on the Timeline.

2.5.2 Timeline Zoom and Navigation

Zoom and Navigation using the Mouse and Keyboard

  • Use the [Mouse Scroll] to zoom in on the Playhead’s location on the Timeline; or

  • Press [Ctrl+Mouse Scroll] to zoom in on the cursor’s location on the Timeline.

Zoom and Navigation using the Zoom Bar

  • Use the Zoom Bar located at the top of the Timeline to zoom in on sections of the Timeline.

  • [Click+Drag] the white handles located at the Zoom Bar’s edges to change the zoom value.

  • [Click+Drag] the center of the Zoom Bar to modify its view position.

2.5.3 Re-center the Playhead

  • [Double-click] on the Zoom Bar to center the Timeline view on where the Playhead is positioned; or

  • Press [F5] (the Timeline must be in focus) to re-center the Playhead.

2.5.4 Scroll and Pan on the Timeline

Scroll

To scroll up or down on the Timeline you can:

  • Place the cursor in the Screen name column at the left of the Timeline; or

  • Place the cursor on the scrollbar at the far right edge of the Timeline.

Pan

To pan left and right on the Timeline: *Using the mouse, [Middle-click+Drag] anywhere in the Timeline’s tracks.

2.5.5 J K L

You can use the [J], [K] and [L] keys to control the Playhead speed during playback. Playhead speed can be increased up to 40 times its normal speed in both directions.

  • Press the [J] key to reverse playback (1 times) speed.

  • Press the [K] key to pause playback.

  • Press the [L] key to playback forward at (1 times) speed.

2.5.6 Navigate Timeline Using Ins and Outs

Clip time boundaries (the In and Out points) can be used to navigate through the Timeline.

  • Press [Ctrl+J] to make the Playhead jump backward to the next In or Out point on the Timeline.

  • Press [Ctrl+K] to make the Playhead jump forward to the next In or Out point on the Timeline.

2.6 Editing on the Timeline

2.6.1 Move Clips

Clips can be moved horizontally on the Timeline in order to change the timing of their occurrence. They can also be moved vertically through the Layers of the same Screen or from one Screen to another.

  • [Left-click+Drag] a Clip to move it.

  • [Left-click+Drag] on the Timeline to draw a selection frame around the Clips you want to move, then [Left-click+Drag] one of the Clips in the selected group to move the whole group.

Clips can also be moved horizontally on the Timeline by first locking the Duration time slider and then by modifying the value of the In or the Out time sliders located in the Shared Clip Properties window section.

2.6.2 Change Clip Duration

Clip duration can be changed using any of the following methods:

  • Place the cursor over the beginning or the end of a Clip (its In or Out point). The cursor’s appearance will change showing a double-ended arrow instead of the regular mouse pointer. [Left-click+Drag] the In or the Out point to change the Clip’s length (i.e. extend or reduce its duration). This method works as well when multiple Clips are selected.

  • Click on the Clip to select it. Enter new values in the In and Out time sliders located in the Shared Clip Properties window section.

2.6.3 Set a Clip’s In or Out Point

Setting a Clip’s In or Out point will move it on the Timeline until it’s beginning or end matches the position specified by the Playhead’s location. The Clip’s duration will not be altered.

Set Clip In Point

  • Click on a Clip to select it. Press [Ctrl+Home] to set the Clip’s In point; or

  • [Right-click] on a Clip to open a contextual menu. Select {Edit > Set clip in point}.

Set Clip Out Point

  • Click on a Clip to select it. Press [Ctrl+End] to set the Clip’s Out point; or

  • [Right-click] on a Clip to open a contextual menu. Select {Edit > Set clip out point}.

2.6.4 Set Clip Fade In/Out Points

Setting a Clip’s Fade In point or Fade Out point will move the Clip on the Timeline until the highest part of the fade slope matches the current position of the Playhead.

Set Clip Fade In Point

  1. Position the Playhead on the Timeline where you want the selected Clip’s fade in to be complete.

  2. Click on the Clip to select it.

  3. Set the Fade In point by using one of the following methods:

    1. Press [Ctrl+Shift+Home]; or

    2. Select {Edit > Set clip in point} from the Timeline menu; or

    3. [Right-click] on the Clip to open a contextual menu. Select {Edit > Set clip in point}.

Set Clip Fade Out Point

  1. Position the Playhead on the Timeline where you want the selected Clip’s fade out to start.

  2. Click on the Clip to select it.

  3. Set the Fade Out point by using one of the following methods:

    1. Press [Ctrl+Shift+End]; or

    2. Select {Edit > Set clip out point} from the Timeline menu; or

    3. [Right-click] on the Clip to open a contextual menu. Select {Edit > Set clip out point}.

Clip fade in and fade out times are set in the Shared Clip Properties window section of the Timeline module.

2.6.5 Trim Clip In or Out Point

Trimming a Clip In or Out point will change the selected Clip’s duration by moving its beginning or end to match the Playhead’s current position. Multiple Clips can be trimmed at the same time.

Trim Clip In Point

  • Click on a Clip to select it. Press [Ctrl+[ ] to trim the Clip’s In point; or

  • [Right-click] on a Clip to open a contextual menu. Select {Edit > Trim clip in point}.

Trim Clip Out Point

  • Click on a Clip to select it. Press [Ctrl+ ] ] to trim the Clip’s Out point; or

  • [Right-click] on a Clip to open a contextual menu. Select {Edit > Trim clip out point}.

2.6.6 Duplicate Clip

Duplicating a selected Clip will create a copy of it in a newly created Layer located beneath it. It is possible to accomplish this operation multiple selected Clips.

  • Click on a Clip to select it. Press [Ctrl+D] to duplicate the Clip; or

  • Click on a Clip to select it. Select {Edit > Duplicate Clip} from the Timeline Editor menu.

When duplicating a Clip, it is also possible to position it in any Layer that exists.

  • Click on a Clip to select it. Press [Ctrl+Left-click+Drag] to duplicate the Clip and position it in any Layer that exists.

2.6.7 Slice Clip

Slicing a Clip will separate it into two distinct Clips.

  1. Position the Playhead on the Timeline where you want the Clip to be sliced.

  2. Click on the Clip to select it.

  3. Slice the Clip by using one of the following methods:

    1. Press [Ctrl+B]; or

    2. Select {Edit > Slice} from the Timeline menu; or

    3. [Right-click] on the Clip to open a contextual menu. Select {Edit > Slice}.

If the sliced Clip is a Media Clip, the In and Out time sliders for the new Media Clips created will be set to reflect the Playhead’s position when the slicing occurred. The In and Out time sliders for Media Clips are in the Media Properties window section.

2.6.8 Snapping

Snapping is a Timeline editing function that facilitates Clip alignment.

  • Press [Shift] while moving a selected Clip to enable Snapping.

If Snapping is enabled, the Clip that you are moving on the Timeline will automatically align with or snap to the edge of another Clip in range. White vertical lines appear at the edges of the Clips that are in range.

Snapping can help ensure you don't accidentally insert or overlay a Clip onto another when dragging Clips around within the Timeline.

Snapping also works between the edge of a Clip and the Playhead (not the other way around).

2.7 Inserting Cues on the Timeline

Cue Clips are used to insert pre-recorded Cues on the Timeline. Cue recording and editing is covered in another section of the manual. (See Section 1.2 Cue Recording in Chapter 4 Programming a Show.)

A Cue will be triggered whenever the Playhead intersects with the Cue Clip that is linked with it.

Follow the next steps to properly insert and adjust a Cue on the Timeline.

2.7.1 Add a Cue Clip

  • [Right-click] in a Layer track to open the Clip Type contextual menu. Select {Add Cue}; or

  • Select a Layer by clicking on its entry in the Layers list. Select {File > Add Cue} from the Timeline Editor menu; or

  • Select a Layer by clicking on its entry in the Layers list. Press [Ctrl+U]. Notice that the Cue Clip’s In point will match the position of the Playhead.

2.7.2 Adjust a Cue Clip’s Length and Position

  • A Cue Clip’s length and position can be adjusted as per any other Clip types. Please refer to previous sections of the manual for detailed instructions. (See Section 2.5.1 Move Clips in Chapter 4 Programming a Show; as well as Section 2.5.2 Change Clip Duration in Chapter 4 Programming a Show.)

A Cue Clip’s length and position should be determined using the following methods:

  • The Cue Clip’s position has to match the moment at which you need it to be triggered.

  • The Cue Clip’s duration should exceed 30 frames to make sure it’s registered even if poor server performances occur.

  • The Cue Clip’s duration should be long enough to allow the operator to read its name in the Timeline.

  • The Cue Clip’s duration should be short enough to avoid visually cluttering the Timeline.

  1. Click on the Cue Clip to select it. Properties specific to the selected Clip will appear in the top right window section of the Timeline module. (The window section should be named Clip Properties.)

  2. Select the Cue you want to link to the Clip by clicking on its entry in the Select source cue list. You can use the search box or select an item from the Cue playlist dropdown menu to filter out unwanted Cues from the Select source cue list.

Once linked, the Cue Clip’s name (shown in the Timeline) will change to the Cue’s name. It should read as: Cue # : name_of_the_Cue (the Cue # is it’s unique ID number).

2.8 Universal Crossfade

The Universal Crossfade widgets can be found in the far left part of the Timeline Editor window section.

This function allows you to execute a crossfade from any point to an other in the Timeline. If the Playhead jumps from any location to an other on the Timeline, a smooth transition will occur. The number and type of Clips (Media, FX, Input Device) being read at each location does not matter; the system will still execute a smooth crossfade between the two states.

Enable Universal Crossfade

  • Click on the [Enable] toggle to activate or deactivate the Universal Crossfade function.

Set Universal Crossfade Duration

  • [Click+Drag] the Cross Fade Slider (measured in seconds) to set the Universal Crossfade duration.

The Universal Crossfade function will only work if PHOTON detects a Playhead jump that has a duration greater than 1 second.

2.9 Timeline Duration

The Timeline’s duration is determined by the Sequence’s duration. By default, a Sequence has a duration of 2 hours. Every newly created Sequence will have this duration if the default value isn’t changed.

2.9.1 Change the Default Value for Sequence Duration

  1. Open the Settings module by pressing [Alt+S] or by selecting {System > Settings}.

  2. Click on the [General] tab.

  3. Click on the Sequence time slider located underneath the Timeline window section to edit its default value.

  4. Enter the new default values for Sequence duration using the keyboard. Values are expressed as follows: hours:minutes:seconds:frames

2.9.2 Change the Duration of a Sequence

  1. [Right-click] on the Sequence tab to open a contextual menu.

  2. Select {Properties} from the menu; a Sequence Properties window will open.

  3. Click on the Duration time slider to edit its default value.

  4. Enter the new default values for Sequence duration using the keyboard. Values are expressed as follows: hours:minutes:seconds:frames

  5. Click on the [OK] button. The Timeline will be extended or reduced to match the Sequence’s duration.

  6. A dialog box will open to tell you if some Clips are out of range now that the Sequence duration has been altered. This is non-destructive; if the Timeline’s duration is returned to its original format the Clips will be reintegrated.

30 hours is the maximum duration for a Sequence because this is the maximum value for Timecode data. 1 second and 1 frame (00:00:01:01) is the minimum duration for a Sequence. (This is arbitrary.)

2.10 Timeline Auto Loop

Playback will automatically stop by default when the Playhead reaches the end of a Sequence,

PHOTON can be set to loop playback automatically. When the Playhead reaches the end of the Sequence it will automatically jump back at 00:00:00:00 and playback will resume.

Auto Loop a Sequence

  1. [Right-click] on the Sequence tab to open a contextual menu.

  2. Select {Properties} from the menu; a Sequence Properties window will open.

  3. Click on the [Enable Auto Loop] toggle to enable the function.

  4. Click on the [OK] button to close the window.

It is possible to create a playback loop in a Sequence by placing a Cue Clip at its end. The pre-recorded Cue has to move the Playhead to the beginning of the Sequence.

2.11 Timeline Freerun

The Freerun function will activate media playback when the Playhead comes into contact with a Media Clip, even if the playback transport function is not enabled. Once activated, the Freerun function will affect the behavior of every Media Clip in the Timeline.

Activate Freerun

  • Click on the [Free Run] toggle located in the Timeline Editor window section to enable Timeline Freerun.

When used on an entire Timeline, this option is very useful as a creation tool. Free Run should not be used in a show.

2.12 Duplicating, Exporting and Importing a Sequence

A Sequence can be duplicated, and it can be exported or imported as a .seq file.

2.12.1 Duplicate a Sequence

  1. [Right-click] on the Sequence tab to open a contextual menu.

  2. Select {Duplicate} from the menu; this will create a copy of the Sequence.

Problems related to Cues and Mappings might be experienced when duplicating a Sequence. Caution is advised.

2.12.2 Export a Sequence

  1. [Right-click] on the Sequence tab to open a contextual menu.

  2. Select {Export} from the menu. A dialog box will open and ask for the name and location of the exported Sequence.

  3. Enter the exported Sequence file name and choose a location. Click on the [Save] button.

2.12.3 Import a Sequence

  1. Select {File > Import sequence} from the Timeline Editor menu. A dialog box will open and ask which Sequence file to load.

  2. Select the .seq file you want to load. Click on the [Open] button.

This action will add the imported Sequence as new tab in the Timeline.

Importing a Sequence into another project is possible, but given that the Timeline is Screen-based, the 3D Scene objects corresponding to the Timeline Screens need to be present in the 3D Scene prior to the import. Cues will have to be rebuilt because they are project dependent for the most part.